1 Zur Vorbereitung

Werbung
Labor zur Vorlesung Technische Optik
Versuch 2: Fizeau-Interferometer
1 Zur Vorbereitung
Sie sollten mit den folgenden Begriffen umgehen können:
Interferenz, Michelson-, Fizeau-Interferometer, Phasenschieben, Referenzwelle, Referenzfläche,
Unwrapping, Seidel- und Zernike-Koeffizienten
2 Software
INTOMATIK-N ist ein leistungsfähige Software zur Ansteuerung des Laserinterferometers
V-100/P des Herstellers MÖLLER-WEDEL OPTICAL GmbH zur Messung optischer
Komponenten. Dieses System bietet dem Anwender die Möglichkeit der schnellen
Konturvermessung
nach dem Prinzip der Phasenschiebung. INTOMATIK-N weist folgende
wichtigsten Leistungsmerkmale auf:
• Betriebssystem Windows NT 4.0,
• Phasenschiebeauswertung,
• Datenvisualisierung durch 2D-, 3D- und Konturdarstellung,
• Dateninterpretation durch Zernike-Koeffizienten, Seidel-Koeffizienten und Asphärenkoeffizienten,
• Permanentes Live-Interferogramm,
• Schnelle Open-GL kompatible Graphik-Darstellung,
• Unterschiedliche Algorithmen zur Phasenentfaltung,
3 Physikalische Grundlagen der Interferometrie
3.1 Interferenz, Interferometergleichung, Unwrapping und Höhenprofil
Das Prinzip der Formprüfinterferometrie besteht im optischen Vergleich einer zu prüfenden
Fläche mit einer planen oder sphärischen Referenzfläche exakt bekannter Form.
Um die geforderten Meßunsicherheiten im Submikrometerbereich zu erreichen, kann
auch hier die Wellenlänge eines Helium/Neon-Lasers von 632,8nm als Maßstab verwendet
werden. Allerdings muß für die Formprüfung zunächst eine Wellenfront bekannt
hoher Formgenauigkeit erzeugt werden.
Seite 1 von 49
Versuch 2: Fizeau-Interferometer
Abbildung 3.1: Prinzip der Formprüfinterferometers nach Fizeau und
Twyman-Green
Wie in Abb. 3.1 prinzipiell dargestellt, wird die vom Laser emittierte ebene Wellenfront
geringen Durchmessers durch ein Raumfilter von hochfrequenten Störungen befreit und
in eine Kugelwelle transformiert. Diese trifft auf den Kollimator, eine speziell ausgelegte
qualitativ hochwertige Optik, die die Kugelwelle in eine ebene Welle umwandelt. Abweichung
dieser Wellenfront von der Planarität im Bereich von nur ca. 30nm (l /20) können
erreicht werden.
Die Wellenfront wird in zwei Wellen aufgeteilt. Meßwelle und die Referenzwelle treffen
auf Meßobjekt und auf die Referenzfläche und werden dort reflektiert. Dabei prägt sich
der Meßwelle die Prüflingsform auf während die Referenzwelle ohne Deformation reflektiert wird. Beide Wellen überlagern sich und es kommt zur Interferenz und damit zu
Ausbildung eines Interefrenzmusters, das von einer Kamera detektiert werden kann. In
der Formprüfinterferometrie wird jedoch darauf geachtet, daß die Wellen zu Wellenfronten
hoher Formgüte mit Durchmessern bis zu 150mm aufgeweitet werden, da sie für die
Güte dieser Meßtechnik entscheidend sind.
Im Falle des Twyman-Green-Interferometers, in Abb. 4.1 rechts dargestellt, sind Referenzund
Meßarm räumlich voneinander getrennt. Um dies zu erreichen, wird ein Strahlteiler
eingesetzt, der die Wellenfront im Intensitätsverhältnis 50:50 aufteilt. Beide Teilwellenfronten
werden mit jeweils einer Optik kollimiert. Während die Referenzwellenfront von
einem als Referenz fungierenden Präzisionsplanspiegel ohne Änderung der Phase in
sich zurück reflektiert wird, trifft die Meßwellenfront auf den Prüfling. Bei der Reflexion
am Prüfling wird der Meßwellenfront nun gleichsam das Profil des Prüflings aufgeprägt.
Eine Abänderung der ursprünglich konstanten Phase f der Meßwellenfront in eine Verteilung
f (x,y) ist die Folge. Die Information über das Höhenprofil z(x,y) des Prüflings
ist somit in dieser Phasenverteilung enthalten. Die so geformte deformierte Meßwellenfront
Seite 2 von 49
Versuch 2: Fizeau-Interferometer
interferiert mit der reflektierten Referenzwellenfront nach deren Überlagerung am
Strahlteiler und es kommt zur Ausprägung eines Interferogramms.
Beim in Abb. 3.1, links, dargestellten Fizeau-Interferometer, der Ausführungsform, die
auch beim V-100/P vorliegt, wird der Referenzarm gleichsam in den Meßarm hineingedreht,
wodurch ein zweiter Kollimator nicht nötig ist. Anstelle eines Referenzspiegels
kommt dann eine hochwertige Glasplatte, in der Regel aus BK7 gefertigt, als Referenz
zum Einsatz, die die Referenzwelle mit ca. 4% der Intensität reflektiert, während die
Meßwelle transmittiert wird. Um die Intensitäten beider Wellen anzupassen und den
Kontrast
  ( x, y ) 
I max  I min

I max  I min
zu optimieren, müssen dann jedoch Abschwächungsfilter eingesetzt werden.
Das Interferenzmuster repräsentiert folglich die Formabweichung der Prüflingsfläche relativ
zur eingesetzten Referenzfläche. Im Falle einer planen Referenz entspricht diese
Formabweichung dem Höhenprofil des Prüflings. Der Kollimator und eine weitere Optik,
die gemeinsam ein Kepler-Teleskop repräsentieren, bilden das Interferogramm verkleinert
auf die Kamera im Auswertearm ab. Es wird von einem CCD-Sensor detektiert und
über eine Framegrabber-Karte der Auswertesoftware zugeführt.
Die mathematische Beschreibung des auftretenden Interferenzmusters ist in Gleichung
3.2 dargestellt. Es ist jedoch zu berücksichtigen, daß die Phase der Wellenfront nicht
konstant ist sondern eine über die Fläche ausgedehnte Phasenverteilung darstellt. Folglich
gilt die Interferometergleichung
(3.2)
I ( x, y)  I 0 (1   ( x, y) cos( ( x, y)   ))
wobei o.B.d.A. angenommen wurde, daß die konstante Phase der Referenzwellenfront
0 ist. Wieder gilt es, aus einer Gleichung mit drei Unbekannten die Verteilung (x,y) zu
extrahieren, da hierin die Information enthalten ist. Dies kann z.B. mit der Phasenschiebetechnik
geschehen, die nun kurz beschrieben werden soll.
Wird im Falle des Fizeau-Aufbaus die Referenzfläche definiert bewegt, ändern sich die
optischen Weglängen im Interferometer. Dies führt zu einer Verschiebung der Streifen
im Interferogramm und somit zu einem additiven Phasenterm a in Gleichung 3.2 . Indem
n Schiebungen um Winkel n×durchgeführt werden und jeweils die Intensitäten
des Interferogramms In(x,y) gemessen werden, kann ein lösbares Gleichungssystem
erzeugt und die Phasenvereilung (x,y) der Meßwellenfront berechnet werden.
In der technischen Realisierung wird die Referenzfläche über Piezostellelemente um
definierte Bruchteile der Wellenlänge verschoben und dabei jeweils ein Interferogramm
Seite 3 von 49
Versuch 2: Fizeau-Interferometer
von der CCD-Kamera aufgenommen. Die ermittelten Grauwerte der Kamerapixel werden
bezogen auf Gleichung 3.2 als Intensitätswerte I1(x,y), . . . , In(x,y) mit n3 interpretiert.
Daraus ergibt sich z.B. für n = 5:
(3.3)
  arctan
2( I 2  I 4 )
,
2 I 3  I 5  I1
 :  ( x, y ) ,
I n : I n ( x, y)
Aufgrund der bei dieser Berechnung auftretenden Arcus-Tangens-Funktion ist die resultierende
Phasenverteilung jedoch mehrdeutig. Alle Phasenwerte werden modulo 2
berechnet. Zu jedem einzelnen Wert muß folglich zunächst noch ein Vielfaches von 2
addiert werden, um die Eindeutigkeit herzustellen („Unwrapping“). Das Kriterium, nachdem
diese Vielfache bestimmt wird, ergibt sich direkt aus dem Abtasttheorem.
Es existieren sehr viele Ansätze und Verfahren für das Unwrapping, eine ideale Lösung
kann jedoch nicht angegeben werden. Es hängt im allgemeinen von der Qualität des
Meßresultates ab, ob komplexe oder einfache Methoden Anwendung finden. Schließlich
wird durch Skalierung mit der eingesetzten Wellenlänge das quantitative Höhenprofil
rekonstruiert:
(3.4)
z ( x, y ) 

2  2
 ( x, y )
Das Höhenprofil des Prüflings ist somit ermittelt.
In Abb. 3.2 ist die Prozedur der Phasenschiebung illustriert. Oben dargestellt sind die 5
phasengeschobenen Interferogramme. Bei dem hier eingesetzten 5-Bild-Verfahren wird
die Phase in fünf Schritten insgesamt um 2verschoben, so daß das fünfte Interferogramm
dem ersten entsprechen muß. Diese Bedingung kann herangezogen werden,
um das Piezostellelement des Phasenschiebers zu kalibrieren.
Nach der Berechnung mittels Gleichung 3.2 ergibt sich dann die Darstellung in Abb. 3.2,
unten links. Man erkennt, daß die Phaseninformation erhalten wurde, jedoch aufgrund
des Arcus-Tangens noch mehrdeutig ist. Schließlich ist in Abb. 3.2, unten rechts das
Ergebnis nach der Unwrapping-Prozedur und der Skalierung entsprechend Gleichung
3.4 dargestellt. In diesem Beispiel handelte es sich um die Messung eines verkippten
Planspiegels.
Seite 4 von 49
Versuch 2: Fizeau-Interferometer
Abbildung 3.2: Prinzip der Formprüfinterferometer nach Fizeau und
Twyman-Green
4. Struktur von INTOMATIK-N
4.1 Allgemeines
INTOMATIK-N wurde speziell an die Hardwaremodule des Interferometers V-100/P angepaßt.
Insbesondere der vorhandene Phasenschieber und dessen Ansteuerung können
erhalten bleiben. Abb. 4.1. zeigt die Struktur von INTOMATIK-N.
Nach der Aufnahme durch eine CCD-Kamera und Zuführung der Interferogrammdaten
an den Steuerrechner mittels eines Framegrabbers kann im Aufnahmemodul optional
eine Datenfilterung zur Glättung des Interferogramms durchgeführt werden. Der Steuerrechner
führt dann über einen DA-Wandler und über Piezostellelemente die Phasenschiebung
der Referenzoptik durch. Die aufgenommenen Interferogrammdaten werden
im DV-Modul nach verschiedenen, frei wählbaren Phasenschiebealgorithmen verknüpft
und die Mehrdeutigkeiten anschließend mit einem Entfaltungs-Algorithmus (s. Abschnitt
6.5.2) behoben. Eine Filterung der Daten zur Rauschreduktion kann vorgenommen
werden, ehe im Ausgabemodul eine Visualisierung der Daten numerisch in Form von
Zernike-Koeffizienten oder aber in Form von 2- oder 3-dimensionalen Graphiken erfolgt.
An dieser Stelle werden nun einige technisch besonders interessante Merkmale der
Software INTOMATIK-N ausführlicher vorgestellt.
4.2 Hardwareansteuerung
Viele kommerzielle Softwareprodukte zur Ansteuerung von phasenschiebenden Interferometern
weisen für den Anwender den Nachteil auf, daß die Software stets von der
Seite 5 von 49
Versuch 2: Fizeau-Interferometer
Abbildung 4.1: Interne Struktur der Interferometersteuersoftware
INTOMATIK-N: Aufnahme, Datenverarbeitung und Ausgabe.
jeweils eingesetzten Hardware abhängig ist. Bei INTOMATIK-N dagegen wurde ein Minimum
an spezifischen Funktionen der Hardwarekomponenten verwendet und zusätzlich
in separaten Modulen implementiert.
4.3 Framegrabber und Kamera
Gerade für die Interferometrie kommt diesen Hardware-Komponenten eine besondere
Bedeutung zu, da der Meßbereich eines Formprüfinterferometers aufgrund des Abtasttheorems
direkt von der Auflösung des Sensors abhängt. Mit der neuen Software
INTOMATIK-N kann durch Auslesen aller zur Verfügung stehenden 768x578 Sensorpixel
eine Meßbereichserweiterung um einen Faktor 3 in der horizontalen Richtung im Vergleich
zur früheren Version erreicht werden, da die unter Beibehaltung des SamplingTheorems meßbaren lokalen Steigungen des Prüflings durch die bessere Abtastung
entsprechend vergrößert werden konnten.
Um dem Ideal der maximalen Unabhängigkeit von Software und Hardware nahezukommen,
wurden die häufig eingesetzten komplexen Framegrabber-Lösungen mit ausführlicher
Softwarebibliothek umgangen und ein einfaches System der Fa. Matrix Vision
(MVSigma SLG) eingesetzt. Von der zur Verfügung stehenden Softwarebibliothek wurde
lediglich der Befehl zur Aufnahme eines Bildes und zum anschließenden Transfer
in den Arbeitsspeicher des Host-Rechners benutzt. Die Funktion wurde in eine DLL
ausgelagert, auf die das Hauptprogramm zugreift. Damit wurde gewährleistet, daß der
Aufwand zur Implementation anderer Framegrabber und Kameras möglichst gering ist,
da lediglich die DLL neu erstellt werden muß.
Seite 6 von 49
Versuch 2: Fizeau-Interferometer
4.4 DA-Wandler zur Phasenschieberansteuerung
Die Problematik beim Phasenschieber entspricht weitestgehend der beim Framegrabber
aus dem vorigen Abschnitt. Um bei INTOMATIK-N dem Gedanken der Modularisierung
weiter nachzukommen, werden über eine definierte mit dem jeweiligen Phasenschieber
abzustimmende Schnittstelle einfach mit 12 Bit digitalisierte Spannungen für
die Phasenschiebung ausgegeben. Diese werden dann vom Phasenschiebemodul in
eine geeignete Steuerspannung für den Piezo-Steller transformiert.
4.5 OpenGL-Graphik-Standard
Als OpenGL wird ein 3D-Graphikstandard des Computerherstellers Silicon Graphics
Inc. (SGI) und diversen Graphikkartenherstellern bezeichnet. Über diesen Standard
können auf einfache Weise komplexe 3D-Graphiken implementiert werden, wie zum
Beispiel die 3D-Ausgabe der gemessenen Prüflingsoberflächen. Dies geschieht über
eine vom Betriebssystem zur Verfügung gestellte Funktionsbibliothek. Vorteil ist dabei
eine weitreichende Hardwareunterstützung. Zeitaufwendige Operationen werden von
einem zusätzlichen Graphikprozessor, der sich auf der Graphikkarte befindet, übernommen
werden, was wiederum die CPU stark entlastet.
4.6 Visualisierungsmodul
INTOMATIK-N besteht aus drei sich ergänzenden Modulen. Im Visualisierungsmodul,
über das die übrigen Module zur Interferogrammaufnahme und zur Live-Interferogrammdarstellung
aufgerufen werden können, findet die Darstellung, Interpretation und eine evtl. Manipulation
der Meßergebnisse sowie die Konfiguration der Software statt.
4.7 Aufnahmemodul
Im Aufnahmemodul wird die Datenaufnahme mittels Phasenschiebung durchgeführt.
Dazu können Operationen wie Maskierung, Datenaufbereitung und Filterung, Entfaltung
und Kalibrierung durchgeführt werden. Nach der Aufnahme werden die Daten an das
Visualisierungmodul übergeben.
Seite 7 von 49
Versuch 2: Fizeau-Interferometer
4.8 Live-Interferogramm
Um z.B. die Justierung des Interferometers auch am PC-Monitor zu erleichtern, wurde
die Live-Darstellung des Kamerabildes in einem eigenen Thread implementiert. Diese
Darstellung kann permanent geöffnet bleiben und somit auch bei der Phasenschiebung
Aufschluß über die Entwicklung des Interferogramms geben.
5. Hinweise zur Benutzung der Software-Hilfe
Diese Dokumentation geht sequentiell vor und beschreibt die Benutzung von INTOMATIKN
anhand aller auftretenden Menü-Punkte. Zu jedem korrespondierenden Fenster, das
mittels Screenshot illustriert ist, werden die Funktionalitäten erläutert. Triviale Funktionalitäten
wie z.B. „Datei speichern“ werden nicht weiter detailliert.
6. Visualisierungsmodul zur Darstellung von gemessenen Daten
Zunächst sei das Hauptmodul von INTOMATIK-N vorgestellt, das nach dem Start der
Software immer aktiv ist.
6.1 Pull-Down Menü „Datei“
6.1.1 Öffnen
Das Standarddartenformat von INTOMATIK-N lautet „*.inn“ . Neben diesem Format werden
folgende weiteren Datenformate folgender Plattformen unterstützt:
• Vorgängerversion des V-100/P INTOMATIK-P (*.map, Version 2 und 3)
• WYKO Vision (*.opd)
• Phasendaten (double) ohne Header im intel- und non-intel Format (*.pha)
• Datenformat des Fraunhofer IPT im intel- und non-intel Format (*.ipt)
Seite 8 von 49
Versuch 2: Fizeau-Interferometer
6.1.2 Schließen / Alle schließen
Wie bei Windows üblich werden mit diesen Funktionen die aktuelle oder alle geöffneten
Dateien geschlossen.
6.1.3 Aus Zernike-Koeffizienten berechnen
Diese Option erlaubt die synthetische Berechnung von Oberflächenprofilen aus ZernikeKoeffizienten.
6.1.3.1 Allgemeines
Zernike-Polynome bilden einen vollständigen Satz orthogonaler Polynome, die auf dem
Einheitskreis definiert sind. Dies macht sie zu einer beliebten Möglichkeit der Datenreduktion
von Wellenfronten in der Interferometrie. Zudem stehen die Polynome in engem
Zusammenhang zu den Seidel-Aberrationen. Die Zernike-Polynome mit der Ordnung n
lassen sich wie folgt angeben:
(6.1)
Z nn2 m (  , )  Rnn2 m (  ) exp( i(n  2m) )
Alternativ können die Zernike Polynome auch reell definiert werden:
(6.2)




 1 n2 m
 Z n( n2 m )  Rnn2 m (  ) cos(i (n  2m) )
 2 Z n
n2 m
U n (  , )  
 1 Z n2 m  Z ( n2 m )  R n2 m (  ) sin(( n  2m) )
n
n
 2i n
Der radiale Term ergibt sich aus:
m
(6.3)
Rnn 2 m (  )   (1) s
s 0
(n  s )!
  n2 s
s!(m  s )!(n  m  s )!
Nachfolgend sind die acht wichtigsten Polynome in dieser Nomenklatur aufgeführt. Dabei
enthält die vierte Spalte eine Numerierung der Zernike-Polynome, wie sie häufig in
kommerziellen Interferometern zur Verfügung steht und wie sie auch in der im Rahmen
der Software INTOMATIK-N implementiert wurde.
6.1.3.2 Eingabe von Zernike Koeffizienten
Um nun aus einer gegebenen Folge von einzelnen Zernikekoeffizienten ein entsprechendes
Oberflächenprofil zu generieren, können diese im entsprechenden Fenster
eingegeben werden. Zusätzlich können eingegebene Werte nachträglich ausgeblendet
werden, ohne daß sie ihren Wert verlieren.
Seite 9 von 49
Versuch 2: Fizeau-Interferometer
Zernike-Koeffizient
Zernike-Polynom
Bedeutung
C0
1
konstanter Term
C2
  sin(  )
Verkippung Y-Achse
C1
  cos( )
Verkippung X-Achse
C5
 2  sin( 2 )
Astigmatismus 45°
C3
2 2 1
Defokussierung
C4
 2  cos(2 )
Astigmatismus bei 0° oder 90°
C7
(3 3  2  )  sin(  )
Koma 3.Ordnung X-Achse
C6
(3 3  2  )  cos( )
Koma 3.Ordnung Y-Achse
C8
6 4  6 2  1
Sphärische Aberration 3.Ordn.
Tabelle 6.1: Zernike-Koeffizienten, Definition und Bedeutung
6.1.4 Aus Asphärenkoeffizienten berechnen
Neben der Parametrisierung durch Zernike-Koeffizienten ist eine Anpassung der allgemeinen
optischen Gleichung möglich. Diese hat die Form
(6.4) z ( x, y ) 
cr2
1  1  (1  k )c r
2 2
 A1r 2  A2 r 3  A3 r 4  A4 r 5  ...,
mit r 
x2  y2
Auch hier können wie bei der Zernike-Darstellung die Koeffizienten mit Werten belegt
und ggf. ausgeblendet werden.
Seite 10 von 49
Versuch 2: Fizeau-Interferometer
Sowohl bei der Zernike- wie auch bei der Asphärengeneration existiert ein Optionsmenü,
mit dem allgemeine Randbedingung zur Generation von Wellenfronten bzw. Oberflächenprofilen festgelegt werden können. So wird die Bildgröße in Pixeln durch Breite
und Höhe festgelegt. Die Wellenlänge , mit der die Wellenfront skaliert wird um mittels
(6.5)
z ( x, y )  W

 ( x, y )
2
auf das Höhenprofil zu schließen, kann genauso wie der Wedgefaktor W eingegeben
werden. Da die Zernike-Koeffizienten auf dem Einheitskreis definiert sind, kann dieser
durch Mittelpunkt und Radius in Pixeln definiert werden, was die Generierung von dezentrierten
Profilen erlaubt. Der Radius bezieht sich dabei auf den äußersten vom Mittelpunkt
entfernten Datenpunkt. Schließlich kann entschieden werden, ob die Werte für
Bad Data beibehalten werden, das heißt im Falle einer Anpassung durch die
Asphärenbeschreibung
auch anschließend vorhanden bleiben. Auch Maskierungen oder Umrandungen
können somit beibehalten werden. Da für die Berechnungen ein Einheitskreis
definiert wird, kann hier auch ausgewählt werden, ob die Werte außerhalb des Einheitskreises
auf Bad Data gesetzt werden. Ansonsten wird der Einheitskreis auf den vollen
Datenbereich vergrößert.
Schaltet man Bad Data beibehalten aus und Außerhalb des Einheitskreises zu Bad Data
setzen an, so wird erreicht, daß im Falle einer Polynomanpassung einzelne Bad DataBereiche durch angepaßte Daten aufgefüllt werden, die Menge von Fehlstellen somit
reduziert wird.
6.1.5 Aus Seidelkoeffizienten berechnen
Aus den schon erwähnten Zernike-Koeffizienten können verschiedene Justierungsfehler
berechnet werden. So sind die beiden Polynome C1 und C2 sind für die Praxis besonders
Seite 11 von 49
Versuch 2: Fizeau-Interferometer
wichtig, da sie die Verkippung des Prüflings beschreiben. Indem ein Zernike-Fit
an das Meßergebnis durchgeführt wird und anschließend diese beiden Verkippungen
aus dem Ergebnis herausgerechnet werden, ist die softwareunterstützte Korrektur dieser
Dejustierung möglich. Die Polynome der Koeffizienten C3 bis C8 stehen in enger
Verbindung zu den Seidel Aberrationen, die an dieser Stelle vorgestellt werden sollen.
Wie man aus Tabelle 6.2 erkennt, müssen die nicht rotations-symmetrischen Aberrationsterme
dabei aus jeweils zwei Zernike-Koeffizienten zusammengesetzt werden.
Seidel-Aberrationen
Verkippung
Größe
C12  C 22
Winkel
  arctan(
C2
)
C1
Defokussierung
2C3
Astigmatismus
2 C42  C52
  0.5  arctan(
Koma
3 C62  C72
  arctan(
Sphärische Aberration
C5
)
C4
C6
)
C7
6C8
Tabelle 6.2: Seidel Aberrationen: Bezeichnung und Definition.
Der Benutzer hat die Möglichkeit durch Eingabe der Seidel-Koeffizienten eine Oberfläche
zu generieren.
Seite 12 von 49
Versuch 2: Fizeau-Interferometer
6.1.6 Speichern unter
Wie schon im „Öffnen“-Menü können Dateien der verschiedenen hier angegebenen Formate
in INTOMATIK-N gespeichert werden.
6.1.7 Drucken
Das ausgewählte Fenster kann über diesen Menüpunkt gedruckt werden.
6.2 Pull-Down-Menü „Messung“
6.2.1 manuelle Messung
Der Menüpunkt manuelle Messung öffnet das Aufnahmemodul zur Messung durch
Phasenschiebung.
Seite 13 von 49
Versuch 2: Fizeau-Interferometer
6.2.2 Automatische Messung
Bei der automatischen Messung wird das Aufnahmemodul geöffnet, die Messung automatisch
durchgeführt und anschließend die Phase in das Visualisierungmodul übergeben.
Im Visualisierungmodul werden dann die im Menü Einstellungen Berechnungen
gewählten Auswerteschritte dargestellt.
6.2.3 Sondermessungen
In diesem Menüpunkt könne die Sondermessungen Homogenitätsprüfung, Würfeleckenmessung,
Dachwinkelprismenmessung und Absolutprüfung angewählt werden. Dabei
werden halbautomatische Messabläufe durchgeführt, bei denen angepasste Maskentypen
verwendet werden.
Seite 14 von 49
Versuch 2: Fizeau-Interferometer
6.2.3.1 Homogenitätsmessung
Bei der Homogenitätsprüfung wird die Homogenität eines Probekörpers in einem einheitenlosen
Kontourplot dargestellt. Der Versuchsaufbau und die Formeln sind in der
folgenden Abbildung dargestellt. Wenn keine Messung durchgeführt wird, sondern vorhandene
Messungen erneut ausgewerten werden sollen, so muß das Kontrollkästchen
für das automatische Beenden der Aufnahme deaktiviert werden. Dann wird im Aufnahmemodul
eine Messung geladen und über den Menüpunkt Phase übergeben an das
Visualisierungsmodul übertragen.
Homogenitätsmessung Tilted Bei dieser Homogenitätsmessung wir der Probekörper
für die letzte Aufnahme leicht gekippt, um ein Interferogramm von der Rückseite zu
erhalten. Damit tatsächlich nur das Interferogramm von der Rückseite des Prüflings
aufgenommen wird, muß es sich um einen keilförmigen Prüfling handelt.
Das Meßergebnis wird gemäß DIN ISO 10110-4 in Homogenitätsklassen eingeteilt.
Homogenitätsmessung Flipped Bei dieser Homogenitätsmessung wird für die letzte
Messung der Probekörper gedreht, um ein Interferomgramm von der Rückseite des Probekörpers
zu bekommen. Die weitere Auswertung ist identisch mit der Tilted-Methode.
Schwankung der Brechzahl (dimensionslos)
Seite 15 von 49
Versuch 2: Fizeau-Interferometer
M 2  M 1  (n  1)  ( M 3  M 4 )  2k
2T
M 1 ( x, y )  2C  2S  K1
D ( x, y ) 
M 2 ( x, y )  2(1  n) A  2(n  1) B  2C  2 D  2S  K 2
M 3 ( x, y )  2 A  2 S  K 3
M 4 ( x, y )  2 B  2S  K 4
(6.6)
n - Brechnungsindex
T - Probendicke
A - Flächenfehler der Vorderseite der Probe
B - Flächenfehler der Rückseite der Probe
C- Flächenfehler des Spiegels
S - Systemfehler
Seite 16 von 49
Versuch 2: Fizeau-Interferometer
Das Meßergebnis wird gemäß DIN ISO 10110-4 in Homogenitätsklassen eingeteilt.
Homogenitätsmessung mittels Immersionsmethode Bei dieser Homogenitätsmessung
wird der Probekörper zwischen zwei Glasplatten mit hoher Oberflächenqualität
eingebracht. Zwischen den Glasplatten und dem Prüfling befindet sich eine
brechungsindexangepasste
Immersionslösung. Somit werden Oberflächenfehler nicht in das Ergebnis
einbezogen und die Homogenität kann direkt gemessen und gemäß DIN ISO
10110-4 in Homogenitätsklassen eingeteilt werden.
Seite 17 von 49
Versuch 2: Fizeau-Interferometer
6.2.3.2 Würfeleckenmessung
Bei der Würfeleckenmessung wird die Abweichung der drei Winkel vom rechten Winkel
berechnet. Dabei kann eine Single- und eine Double-Pass-Anordnung verwendet
werden.
Würfeleckenmessung Single-Pass Bei der Single-Pass Messung der Winkelfehler
durchlaufen die Strahlen die Würfelecke nur einmal und werden dann in den optischen
Weg des Interferometers zurückreflektiert. Die Single-Pass-Messung ist nur halb so
empfindlich wie die Double-Pass-Messung. Der Versuchsaufbau und die Formeln sind
in der folgenden Abbildung dargestellt. Wenn keine Messung durchgeführt sondern
vorhandene Messungen erneut ausgewerten werden sollen, so wird im Aufnahmemodul
eine Messung geladen und dann durch Drücken des Weiter-Buttons im Visualisierungsmodul
automatisch übertragen und ausgewertet.Bei der Würfeleckenmessung in
Single-Pass-Anordnung werden die sechs sichbaren Würfeleckensegmente maskiert.
Die Verkippung der sechs Segmente gegeneinander und damit die Abweichung von
den 90_ Winkeln wird berechnet.
Winkelfehler:

Seite 18 von 49
Versuch 2: Fizeau-Interferometer
 ij 
 ij
4n 2 / 3

180

 ij   i2   j2  2 i j cos(  i   j )

 i  Tiltwinkeli
i 
Tiltbetrag i  Wellenläng e
ri
Segmentkreisradius i [ Pixel]  Pr obendurchmesser [mm]
2  Pr obeneinhei tskreisradius[mm]
n  Brechung sin dex
ri 

Im Aufnahmemodul muss nun die Würfeleckenmaske mit den Kanten des Probekörpers
in Überdeckung gebracht werden.
Danach wird die Verkippung der Segmente gegeneinander und damit der Winkelfehler
berechnet und in Bogensekunden ausgegeben.
Seite 19 von 49

Versuch 2: Fizeau-Interferometer
Würfeleckenmessung Double-Pass Bei der Double-Pass Messung der Winkelfehler
durchlaufen die Strahlen die Würfelecke zweimal. Der Strahl wird durch die Würfelecke
in Richtung der Referenzplatte reflektiert, durchläuft diese und wird dann durch eine
halb vor die Referenzplatte geschobene Abschattung blockiert. Der dann an der Oberfläche der Referenzplatte reflektierte Strahlanteil durchläuft wiederum die Würfelecke
und wird dann schließlich wieder in den optischen Weg des Interferometers zurückreflektiert.
Die Double-Pass-Messung ist doppelt so empfindlich wie die Single-PassMessung. Der Versuchsaufbau und die Formeln sind in der folgenden Abbildung dargestellt.
Wenn keine Messung durchgeführt sondern vorhandene Messungen erneut
ausgewerten werden sollen, so wird im Aufnahmemodul eine Messung geladen und
dann durch Drücken des Weiter-Buttons im Visualisierungsmodul automatisch übertragen
und ausgewertet. Bei der Double-Pass Messung wird der Aussteuerungswert bei
der Kalibrierung automatisch halbiert.
Winkelfehler:
 ij 
i

180
4n 2 / 3 
Tiltbetrag i  Wellenläng e
i 
ri

Segmentkreisradius i [ Pixel]  Pr obendurchmesser [mm]
ri 
2  Pr obeneinheitskreisradius[mm]
n  Brechung sin dex
Seite 20 von 49
Versuch 2: Fizeau-Interferometer
Bei der Double-Pass Messung sind nur drei Segmente sichtbar. Die Maske muss entsprechend
angepasst werden.
Danach wird die Verkippung der Segmente gegeneinander und damit der Winkelfehler
berechnet und in Bogensekunden ausgegeben.
6.2.3.3 Dachwinkelprismamessung intern
Bei der internen Dachwinkelprismamessung wird die Abweichung des Winkels vom
Seite 21 von 49
Versuch 2: Fizeau-Interferometer
rechten Winkel berechnet. Dabei gibt es eine Single- und eine Double-Pass Anordnung.
Dachwinkel intern Single-Pass Bei der Single-Pass Messung des Winkelfehlers durchlaufen
die Strahlen das Prisma nur einmal und werden dann in den optischen Weg des
Interferometers zurückreflektiert. Die Single-Pass-Messung ist nur halb so empfindlich
wie die Double-Pass-Messung. Der Versuchsaufbau und die Formeln sind in der folgenden
Abbildung dargestellt.Wenn keine Messung durchgeführt wird sondern vorhandene
Messungen erneut ausgewerten werden sollen, wird im Aufnahmemodul eine Messung
geladen und dann durch Drücken des Weiter-Buttons im Visualisierungsmodul automatisch
übertragen und ausgewertet.
Winkelfehler:
 ij 
 ij 180

4n 
 ij   i2   j2  2 i j cos(  i   j )

 i  Tiltwinkeli
i 
Tiltbetrag i  Wellenläng e
ri
Segmentkreisradius i [ Pixel]  Pr obendurchmesser [mm]
2  Pr obeneinheitskreisradius[mm]
n  Brechung sin dex
ri 
Seite 22 von 49
Versuch 2: Fizeau-Interferometer
Die automatisch generierte Maske muss an den Prüfling angepasst werden.
Danach wird die Verkippung der Segmente gegeneinander und damit der Winkelfehler
berechnet und in Bogensekunden ausgegeben.
Dachwinkelprismamessung intern Double-Pass Bei der Double-Pass Messung des
Winkelfehlers durchlaufen die Strahlen das Prisma zweimal. Der Strahl wird durch das
Prisma in Richtung der Referenzplatte reflektiert, durchläuft diese und wird dann durch
eine halb vor die Referenzplatte geschobene Abschattung blockiert. Der dann an der
Oberfläche der Referenzplatte reflektierte Strahlanteil durchläuft wiederum das Prisma
und wird dann schließlich wieder in den optischen Weg des Interferometers zurückreflektiert.
Die Double-Pass Messung ist doppelt so empfindlich wie die Single-Pass
Messung. Der Versuchsaufbau und die Formeln sind in der folgenden Abbildung dargestellt.
Wenn keine Messung durchgeführt wird sondern vorhandene Messungen erneut
ausgewerten werden sollen, so wird im Aufnahmemodul eine Messung geladen und
dann durch Drücken des Weiter-Buttons im Visualisierungsmodul automatisch übertragen
und ausgewertet. Bei der Double Pass Messung wird der Aussteuerungswert bei
der Kalibrierung automatisch halbiert.
Seite 23 von 49
Versuch 2: Fizeau-Interferometer
Winkelfehler:

 ij 
 ij 180

4n 
i 
Tiltbetrag i  Wellenläng e
ri
Segmentkreisradius i [ Pixel]  Pr obendurchmesser [mm]
2  Pr obeneinheitskreisradius[mm]
n  Brechung sin dex
ri 
Die automatisch generierte Maske muss an den Prüfling angepasst werden.
Danach wird die Verkippung der Segmente gegeneinander und damit der Winkelfehler
berechnet und in Bogensekunden ausgegeben.
Seite 24 von 49
Versuch 2: Fizeau-Interferometer
6.2.3.4 Dachwinkelprismamessung extern
Bei der externen Dachwinkelprismanmessung wird die Abweichung des Winkels vom
rechten Winkel berechnet. Bei dieser Messung werden die Strahlen vom Prisma auf
Spiegel reflektiert die die Strahlen zurück zum Prisma und damit in Richtung Refernzplatte
lenken. Der Versuchsaufbau und die Formeln sind in der folgenden Abbildung
dargestellt. Wenn keine Messung durchgeführt wird sondern vorhandene Messungen
erneut ausgewerten werden sollen, so wird im Aufnahmemodul eine Messung geladen
und dann durch Drücken des Weiter-Buttons im Visualisierungsmodul automatisch
übertragen und ausgewertet.
Winkelfehler:
 ij 
i

180
4n / 2 
Tiltbetrag i  Wellenläng e
i 
ri

Segmentkreisradius i [ Pixel]  Pr obendurchmesser [mm]
ri 
2  Pr obeneinheitskreisradius[mm]
n  Brechung sin dex
Seite 25 von 49
Versuch 2: Fizeau-Interferometer
Die automatisch generierte Maske muss an den Prüfling angepasst werden.
Danach wird die Verkippung der Segmente gegeneinander und damit der Winkelfehler
berechnet und in Bogensekunden ausgegeben.
6.2.3.5 Drei Platten Test
Bei dieser Absolutmessung werden drei Platten in unterschiedlichen Kombinationen
gemessen und anschließend die von der Qualität der Referenzplatte unabhängigen
Oberflächenform der Platten entlang fünf verschiedener Geraden berechnet. Der Versuchsaufbau
und die Formeln sind in der folgenden Abbildung dargestellt. Wenn keine
Messung durchgeführt sondern vorhandene Messungen erneut ausgewerten werden
sollen, so wird im Aufnahmemodul eine Messung geladen und dann durch Drücken des
Weiter-Buttons im Visualisierungsmodul automatisch übertragen und ausgewertet.
Seite 26 von 49
Versuch 2: Fizeau-Interferometer
Für die Ermittlung des absoluten Profils der drei Platten entlang von fünf Geraden, die
jeweils um einen Winkel von 37° gekippt sind, wird das folgende Gleichungssystem
sukzessive gelöst:
Gleichung1 : a n  bn  h1, n
Gleichung 2 : a n  cn  h2, n
(6.12)
Gleichung 3 : cn  a n  h3, n
Gleichung 4 : a n  b2 n  h4, n
an(r) - Abweichung von Platte A entlang einem Querschnitt n an Radialpunkt r
hm, n - gemessene Abweichung entlang Querschnitt |n| im Messschnitt m
Schritt
Gleichung
Input
Output
1
1 bis 3
n=0
a0
2
1 bis 3
n=0
b0
3
1 bis 3
n=0
c0
4
4
a0
b2
5
2
b2
c-2
6
4
b0
a2
7
1
a2
b-2
8
2
b-2
c2
9
3
c2
a-2
10
4
a-2
b-4 =b1
11
2
b1
c-1
12
4
b1
a1
13
1
a1
b-1
14
2
b-1
c1
Seite 27 von 49
Versuch 2: Fizeau-Interferometer
15
3
C1
a-1
Das Ergebnis der Auswertung wird in einem Kontour Plot für die berechneten fünf Linien
der Platte A dargestellt.
6.2.3.6 Absolutprüfung
Bei der Absolutprüfung wird der sphärische Probekörper in unterschiedlichen Kombinationen
gemessen und anschließend die von der Qualität der Referenzebene unabhängige
Oberflächenform des Prüflings berechnet. Der Versuchsaufbau und die Formeln sind
Seite 28 von 49
Versuch 2: Fizeau-Interferometer
in der folgenden Abbildung dargestellt.Wenn keine Messung durchgeführt wird sondern
vorhandene Messungen erneut ausgewerten werden sollen, so wird im Aufnahmemodul
eine Messung geladen und dann durch Drücken des Übergabe-Buttons im Aufnahmemodul
automatisch ins Visualisierungsmodul übertragen und ausgewertet.
r
W1  Wref  1 / 2(Wdiv  Wdiv
)
(6.13)
W2  Wref  Wdiv  Wsurf
r
W3  Wref  Wdiv  Wsurf
Wabs  1 / 2(W2  W3r  W1  W1r )
Wn gemessene Wellenfront
Wre f Wellenfront der Bezugsfläche
Wdiv Wellenfront der Zerstreuungslinse
Wr um 180° gedrehte Wellenfront
6.2.4 Kalibrieren
Diese Funktionalität bewirkt, daß der Phasenschieber neu kalibriert wird. Dazu muss
ein Interferogramm eingestellt werden, dass ca. 5 gerade Linien zeigt. Über den Button
Iteration starten werden in einem Iterationsprozess die optimalen Ansteuerwerte für den
Phasenschieber ermittelt. Für eine korrekte Kalibrierung muss die Iteration erfolgreich
abgeschlossen werden und der Schwerpunkt der Verteilung der Phasenverteilung im
Bereich von 85°-95° liegen.
Seite 29 von 49
Versuch 2: Fizeau-Interferometer
6.2.5 Livebild
Hiermit wird die Darstellung eines Live-Bildes des Interferogramms in einer eigenen
Anwendung gestartet. Die Priorität dieser Darstellung kann wie in 6.7.2 beschrieben
geändert werden.
6.3 Pull-Down-Menü „Protokoll“
6.3.1 Protokoll erstellen
Der Menüpunkt Protokoll erstellen erlaubt dem Benutzer, das akivierte Ergebnisfenster
in inkl. der Protokolldaten auszudrucken bzw. als Datei zu speichern.
Seite 30 von 49
Versuch 2: Fizeau-Interferometer
6.4 Pull-Down-Menü „Analyse“
6.4.1 2D-Darstellung
Die 2D-Darstellung erlaubt es, horizontale, vertikale und frei diagonale Schnitte durch
das Meßergebnis zu legen. Der Typus des Schnittes kann angeklickt wertden, die zugehörigen
Parameter können dann in den entsprechenden Fenstern numerisch eingegeben
werden bzw. durch Maussteuerung im oben rechts dargestellten Konturplot frei
ausgewählt werden. Neben der Schnittdarstellung sind die die Messung betreffenden
allgemeinen Daten unterhalb des Plots editiert.
6.4.2 3D-Darstellung
Die 3D-Darstellung erfolgt im OpenGL-Standard. Die Art der graphischen Darstellung
wie auch die gewünschten Zoom-Einstellungen können im Menü Einstellungen - Anzeige
- 3D-Darstellung gewählt werden. Um die Perspektive zu ändern, greift man mit
gedrückter linker Maustaste die Graphik und dreht sie in die gewünschte Perspektive.
Neben der Pixelzahl ist der maximale Höhenwert angegeben. Die übrigen Werte entnimmt
man dem rechts dargestellten Farbbalken. Wie der sind die wichtigen Parameter
der Messung unterhalb editiert.
Seite 31 von 49
Versuch 2: Fizeau-Interferometer
6.4.3 Kontur-Darstellung
Die Konturdarstellung ergänzt 2D- und 3D-Darstellung. Hier ist die Höheninformation
farblich kodiert. Eine Zuordnung zum rechts dargestellten Farbbalken kann durch Bewegung
der Maus erreicht werden. Die wichtigen Dateiparameter siond wieder unten
angegeben.
6.4.4 Rohdaten-Darstellung
Diese Art der Darstellung erlaubt es, aus der Phasenverteilung bzw. dem Höhenprofil die zugehörigen zugrundeliegenden Interferogrammdaten zu berechnen. Sind nach
einer künstlichen Generierung der Daten durch Zernike- oder Asphärenkoeffizienten
keine Interferogramme vorhanden, können diese theoretisch berechnet werden. Deren
Darstellung erfolgt dann automatisch im Aufnahmemodul von INTOMATIK-N.
6.4.5 Fit
Zusätzlich können die Seidel-Aberrationen vom vorliegenden Datensatz entfernt werden.
Dies bietet sich an, um unerwünschte Terme wie Tilt oder Defokussierung zu eliminieren.
6.4.6 Zernike anzeigen/Zernike berechnen
Diese Funktion bewirkt, daß ein ggf. vorhandener Satz von Zernike-Koeffizienten dargestellt
wird. Liegen die Zernike-Koeffizienten noch nicht vor, werden diese für den aktuellen
Datensatz berechnet und dann dargestellt. Neben des 36 Zernike-Koeffizienten
Seite 32 von 49
Versuch 2: Fizeau-Interferometer
werden ebenfalls die daraus resultierenden Seidel-Aberrationen sowie die Definition des
zugrundeliegenden Einheitskreise editiert.
6.4.7 Seidel-Komponenten entfernen
Diese Funktion entfernt die vom Anwender markierten Seidel-Koeffizienten aus dem
gemessenen Datensatz. So bietet es sich immer an, neben Const auch den Tilt also die
Verkippung eines Prüflings abziehen zu lassen.
6.4.8 FFT
Diese Funktion gestattet es, eine FFT in Form einer Point Spread Funktion PSF oder
einer Modulationstransferfunktion MTF durchzuführen.
6.4.8.1 PSF
Diese Funktion bewirkt, daß eine mathematische Berechnung des Fernfeldintensitätsmusters
als Antwort auf eine ideale Punktquelle erfolgt.
Seite 33 von 49
Versuch 2: Fizeau-Interferometer
6.4.8.2 MTF
Diese Funktion bewirkt eine mathematische Analyse, wie verschiedene Frequenzen
durch das optische System geleitet werden.
6.5 Pull-Down-Menü „Manipulation“
6.5.1 Falten
Nach Durchführung der Phasenschiebung wird die ermittelte Phasenverteilung automatisch
entfaltet, d.h. ihre Unstetigkeiten behoben. Dieser Entfaltungsprozeß kann durch
nachträgliches Falten rückgängig gemacht werden. Dabei wird die zugrundeliegende
Phasenverteilung durch Subtraktion entsprechender Vielfacher von 2in das Werteintervall
[-,[ reduziert.
6.5.2 Entfalten
Diese Operation führt wieder zu einer Verstetigung der Phasenverteilung und macht
damit die Operation aus 6.6.1 rückgängig. Sie wird nach der Phasenschiebung standardmäßig
durchgeführt.
Seite 34 von 49
Versuch 2: Fizeau-Interferometer
6.5.3 Begrenzen
Mit dieser Option kann der Datenbereich vom Benutzer eingegrenzt werden, um z.B.
die verfügbare Farbskala auf den interessierenden Bereich anzupassen. Die Grenzen
selbst können durch Minimum und Maximum manuell neu eingegeben werden oder
aber durch Mausklick auf den Farbbalken der jeweiligen Darstellung direkt definiert werden.
Aktuelle Min/Max-Werte werden ebenfalls dargestellt. Die hierdurch ausgeblendeten
Werte werden dabei auf Bad Data gesetzt und stehen daher im Datensatz nicht
mehr zur Verfügung.
6.5.4 Zernike-Filter
Diese Operation führt einen Zernike-Fit an den gemessenen Datensatz durch und stellt
einen aus diesen Koeffizienten berechneten Datensatz in einem neuen Datenfenster
dar. Somit wird die Messung gleichsam auf einen Satz von Koeffizienten reduziert und
dabei eine Glättung des gemessenen Prüflingsprofils erreicht.
Seite 35 von 49
Versuch 2: Fizeau-Interferometer
6.5.5 Rauschfilter
Der Rauschfilter wirkt auf die Phasenverteilung nach der Phasenschiebung, nicht wie in
5.7.2 auf die Interferogramme vor der Phasenschiebung. Der Filtertyp kann ausgewählt
werden, wobei einige Filtertypen wie Median, Gauss, Mittelwertfilter und Kreuzfilter vorgegeben
wurden. Es können jedoch auch eigene Filter frei definiert werden. Darüber
kann die Filtergröße zwischen 3x3 und 5x5 gewählt werden, wodurch das Editierfenster
der Filterparameter entsprechend angepaßt wird.
6.5.6 ISO-konforme Auswertung
Dieser Menüpunkt erlaubt eine ISO-konforme Auswertung der im aktiven Fenster dargestellten
Messung. Dabei werden gemäß der Norm 10110 Teil 5 folgende Fehler bestimmt:
Gesamtpassfehlerfunktion, bestangepasste Kugelfläche, Unregelmäßigkeitsfunktion,
bestangepasste asphärische Fläche und die verbleibende Fläche. Außerdem kann
eine automatische ISO-Auswertung aufgerufen werden.
Seite 36 von 49
Versuch 2: Fizeau-Interferometer
6.6 Pull-Down-Menü „Einstellungen“
6.6.1 Berechnungen
In den Einstellungen kann ausgewählt werden, ob nach jeder Messung die ZernikeKoeffizienten automatisch berechnet werden sollen. Zusätzlich kann die Anzahl der Koeffizienten
eingestellt werden, wobei hier maximal 36 Koeffizienten möglich sind. Der
Verkleinerungsfaktor gibt die Abtastrate für die Stützstellen an. In angebenenen Fall
würde jeder 8. Wert zur Berechnung herangezogen. Die Option der Benutzung von gespeicherten
Matrizen dient speziellen Operationen zur Einsparung von rechenzeit und
sollte nicht gesetzt werden. Zur Definition des Einheitskreises kann die automatische
Definition nach ISO verwendet werden. Darüber hinaus kann der Einheitskreis jedoch
über Mittelpunkt und Radius frei definiert werden.
Die Seidel-Aberrationen können automatisch von einer Messung abgezogen werden,
falls das entsprechende Flag gesetzt wird. In diesem Fall werden die unten angegebenen
Seite 37 von 49
Versuch 2: Fizeau-Interferometer
Seidel Koeffizienten vom Datensatz abgezogen. Der modifizierte Datensatz erscheint
in einem neuen Fenster. Falls das Flag Origionaldaten beibehalten nicht gesetzt
wird, wird nach Ausführung der Operation der ursprüngliche Datensatz gelöscht.
Die Entfaltung im Rahmen der Phasenschiebenden Interferometrie ist ein nicht eindeutig
lösbares mathematisch-physikalisches Problem. Es gibt keine ideale Methode. Vielmehr
muß ein Kompromiß zwischen Geschwindigkeit und Robustheit gegenüber Störungen
im Interferogramm bzw. der durch Phasenschiebung ermittelten mehrdeutigen
Verteilung gefunden werden.
Um hinsichtlich der Geschwindigkeit bei der Entfaltung der durch Phasenschiebung ermittelten
Daten trotzdem flexibel zu sein, wurden drei verschieden Entfaltungsalgorithmen
implementiert.
Bei guten Meßbedingungen und guter Interferogrammqualität bietet sich der Pfadalgorithmus
an, der auch das Standardverfahren darstellt.
Bei schlechten Meßbedignungen bzw. schlechter Interferogrammqualität bieten sich die
beiden auf zellulären Automaten basierenden Verfahren an. Hier ist es sinnvoll, alterantiv
beide Verfahren im jeweiligen Fall zu testen, da beide Vorteile und Nachteile bieten.
Seite 38 von 49
Versuch 2: Fizeau-Interferometer
Diese Option legt eine Referenz- oder Musterdatei fest. Diese Musterdatei sollte durch
Messung einer hochwertigen Referenz- oder Kalibrierfläche erzeugt werden und beinhaltet dann die Fehler des Meßsystems. Bei darauffolgenden Standardmessungen, kann
durch Subtraktion der Musterdatei dieser Systemfehler vom Meßresultat abgezogen
werden, was zu einer Fehlerreduktion im Meßresultat führt. Der Anwender kann auswählen,
ob er die Musterdatei automatisch nach einer Messung abziehen möchte und
ob er die Originaldaten beibehalten möchte, die korrigierte Datei also in einem neuen
Fenster dargestellt wird, und jederzeit wieder auf die nicht korrigierten Daten zurückgegriffen
werden kann. Weiterhin kann angebene werden, ob die Subtraktion nicht bez.
der Weglängen durchgeführt werden soll.
Hier werden die Einstellung der Segmentfilterung von gemessenen Dateien vorgenommen.
Der Anwender kann angeben ob der Filter automatisch nach jeder Messung angewendet
werden soll, ob die Originaldateien beibehalten werden sollen und ob nur das
größte Segment erhalten bleiben soll. Ansonsten werden nur Segmente verwendet, die
Seite 39 von 49
Versuch 2: Fizeau-Interferometer
mindestens die angegebene Pixelzahl haben.
Ebenso kann im Falle des Zernike-Filters angegeben werden, ob diese Operation automatisch
nach jeder Messung durchgeführt wird und ob die Originaldaten beibehalten
7. Aufnahmemodul zur Messung durch Phasenschiebung
Wird eine Messung geladen oder neu am Interferometer durchgeführt, erscheinen zunächst
6 Fenster im Aufnahmemodul wie hier dargestellt.
Dies sind die 5 phasengeschobenen Interferogramme (Image 1 bis Image 5) sowie
eine Differenzdatensatz, bei dem die Differenz der Interferogramme aus Image 1 und
Image 5 gebildet wurde. Zu einer ersten visuellen Kontrolle kann dieser Datensatz gut
herangezogen werden, da im Idealfall diese Differenz 0 sein sollte, das Bild also schwarz
erscheint.
Seite 40 von 49
Versuch 2: Fizeau-Interferometer
7.1 Pull-Down-Menue „Datei“
7.1.1 Messung laden/Messung speichern
INTOMATIK-N speichert Interferogrammdaten wahlweise als Windows-Bitmap (*.bmp)
oder als Intensitätswerte (*.int) mit 1 Byte pro Pixel plus Header ab. Der Name kann frei
angegeben werden, eine generische erzeugte Endung wird automatisch angefügt. Die
phasengeschobenen Interferogramme können daher als Messung auch nachträglich
geöffnet werden und stehen dann für eine weitere Auswertung zur Verfügung.
Außerdem ist als weiteres Datenformat eine Ablage der berechneten Phasenwerte als
Rohdatensatz (*.raw) mit 8 Byte pro Pixel möglich. Hierbei sind jedoch Information über
die Feldgröße manuell einzugeben, da ein Header bei diesem im Gegensatz zu den
anderen Formaten nicht mitgeschrieben wird.
7.1.2 Maske laden/Maske speichern
Ebenso können die Masken geladen werden. Sie liegen parametrisiert im ASCII-Format
vor (*.msk), was auch eine Editierung in herkömmlichen Textverarbeitungsprogrammen
möglich macht.
7.1.3 Phase übergeben
Nachdem die Messung mittels Phasenschiebung durchgeführt wurde bzw. die Meßdaten
geladen wurden, können diese mittels der Funktion Phase übergeben an das
Visualisierungsmodul
übergeben werden. Dabei wird aus den Interferogrammen die entsprechende
Phasenverteilung der Meßwellenfront berechnet und neben den Maskendaten
in einer globalen Struktur übergeben. Diese beinhaltet alle notwendigen Informationen
über die gesamte Messung.
Seite 41 von 49
Versuch 2: Fizeau-Interferometer
7.2 Pull-Down-Menue „Bildverarbeitung“
7.2.1 Messung
Diese Funktion löst eine die Phasenschiebung und Bildaufnahme von 5 Interferogrammen
aus. Die aufgenommen Bilder werden dargestellt. Zur Kontrolle wird darüber hinaus
auch die Differenz der Intenitätsverteilungen 1 und 5 dargestellt. Letztere Verteilung gibt
einen visuellen Aufschluß über die Qualität der Messung, da hier theoretisch aufgrund
der bei der Kalibrierung geforderten Gleichheit beider Verteilungen eine Nullverteilung
auftreten müßte. Die aufgenommenen Interferogramme werden zusammen mit anderen
Informationen in einer globalen Datenstruktur gespeichert. Die Phasenverteilung ist
zu diesem Zeitpunkt noch nicht berechnet. Erst durch Übergabe der Verteilung an das
Visualisierungsmodul wird diese Berechnung durchgeführt.
7.3 Pull-Down-Menue „Anzeige“
7.3.1 Live-Bild
Hiermit wird die Darstellung eines Live-Bildes des Interferogramms in einer eigenen
Anwendung gestartet. Die Priorität dieser Darstellung kann wie in 6.7.2 beschrieben
geändert werden.
7.3.2 Phasenverlauf
Der Einfluß der Phasenschiebung auf einen einzelnen Wert wird hier zu den Zeitpunkten
der Bildaufnahme graphisch dargestellt. Neben den Koordinaten des Punktes im
oberen Bereich werden zusätzlich die Helligkeitswerte und die berechnete Phase, die
Modulation sowie die Summe der einzelnen Intensitäten editiert. Somit kann eine Beurteilung
Seite 42 von 49
Versuch 2: Fizeau-Interferometer
der Phasenschiebung an einzelnen Punkten durchgeführt werden. Neben der
manuellen Eingabe der Pixelkoordinaten kann das zu analysierende Pixel auch über die
Maus ausgewählt werden.
7.3.3 Maske
Die Maskierung der Interferogramme ist zum Erhalt eines guten Meßergebnisses essentiell.
Zwar unterstützten Schwellwerte im Modulationsgrad und auch der Segmentfilter
den Verlauf der Auswertung, allerdings müssen kritische Bereiche des Prüflings und
des gesamten Bildausschnittes ausmaskiert werden.
Neben dem Pull-Down-Menue kann ein Maskededitor auch durch Betätigung der rechten
Maustaste auf dem Interferogramm aufgerufen werden. Dort befindet sich auch der
Menuepunkt Eigenschaften, der in den unteren Darstellungen neben den maskierten
Interferogrammen zu sehen ist.
Den Masken gemein ist, daß jeweils mittels eines Flags entweder der Außenbereich
oder aber der Innenbereich ausmaskiert werden kann.
7.3.4 Auswertung
Mittels dieser Option gelangt man zurück in das Visualisierungsmodul wo die Auswertung
der Messung durchgeführt werden kann.
7.4 Pull-Down-Menue „Maske“
Die Maskierung der Interferogramme ist zum Erhalt eines guten Meßergebnisses essentiell.
Zwar unterstützten Schwellwerte im Modulationsgrad und auch der Segmentfilter
den Verlauf der Auswertung, allerdings müssen kritische Bereiche des Prüflings und
des gesamten Bildausschnittes ausmaskiert werden.
Neben dem Pull-Down-Menue kann ein Maskededitor auch durch Betätigung der rechten
Maustaste auf dem Interferogramm aufgerufen werden (s. a. 7.4.8). Dort befindet
sich auch der Menuepunkt Eigenschaften, der in den unteren Darstellungen neben den
maskierten Interferogrammen zu sehen ist.
Den Masken gemein ist, daß jeweils mittels eines Flags entweder der Außenbereich
oder aber der Innenbereich ausmaskiert werden kann.
7.4.1 keine
Dieser Menuepunkt beendet die Plazierung von Masken mit Hilfe des Masken-Cursors
und stellt den normalen Cursor wieder her.
Seite 43 von 49
Versuch 2: Fizeau-Interferometer
7.4.2 Rechteck
Die rechteckige Maske kann entweder mittels Maus aufgezogen werden oder aber
durch Startpunkt sowie Breite und Höhe numerisch definiert werden. Sie kann nachträglich
durch Klick mit der linken Maustaste auf die Umrandung verschoben und durch
Klick mit der linken Maustaste auf die Knoten vergrößert oder verkleinert werden.
7.4.3 Kreis
Die für Linsen und andere Optiken wichtigste Maske wird bei gehaltener Maustaste
aufgezogen. Sie kann nachträglich durch Klick mit der linken Maustaste auf die Umrandung
vergößert oder verkleinert werden und durch Klick mit der linken Maustaste auf
das Zentrum verschoben werden. Ebenso können Mittelpunkt und Radius auch numerisch
verändert werden.
7.4.4 Ellipse
Seite 44 von 49
Versuch 2: Fizeau-Interferometer
Bei der elliptischen Maske kann die Position und die Länge der Halbachse angegeben
werden.
7.4.5 Polylinie
Diese Maskenform wird sequentiell durch Mausklicks definiert und durch Doppelklick
abgeschlossen. Die Knoten können nachträglich verschoben werden. Die Maske kann
nachträglich durch Klick mit der linken Maustaste auf die Umrandung verschoben werden.
Durch Klick mit der linken Maustaste auf die Knoten können diese einzeln verändert
werden. Zusätzlich werden die das Polygon beschreibenden Punktepaare des
korrespondierenden Eintrags in der Maskendatei editiert.
Seite 45 von 49
Versuch 2: Fizeau-Interferometer
7.4.6 Triple
Für die Auswertung von Würfelecken werden sechs Segmente ausmaskiert.
7.4.7 Masken modifizieren
Die Masken werden in ASCII-Format sequentiell in eine Masken-Datei geschrieben.
Dort ist jede Maske eines bestimmten Datensatzes als einzelnes Objekt abgelegt. Entsprechend
kann man zum Bearbeiten der einzelnen Masken diese Objekte nacheinander
anwählen. Im Menue sind dazu folgende verschiedenen Möglichkeiten vorgesehen
(gehe zum . . .):
• nächsten Maskenobjekt,
• vorhergehenden Maskenobjekt,
• letzten Maskenobjekt.
Darüber hinaus können die jeweils aktuellen Maskenobjekte auf folgende Art und Weise
modifiziert werden:
• invertieren,
Seite 46 von 49
Versuch 2: Fizeau-Interferometer
• löschen,
• über Eigenschaften editieren.
Sondermasken besitzen einen besonderen Status und können nur über rechten Mausklick
Sondermaske Löschen"gelöscht werden.
7.5 Pull-Down-Menue „Fenster“
Unter diesem Menuepunkt können die einzelnen Fenster benutzerdefiniert angepasst
werden.
7.6 Pull-Down-Menue „Hilfe“
Unter diesem Menuepunkt können die Online-Hilfe und Informationen über die Programmversion
aufgerufen werden.
Seite 47 von 49
Versuch 2: Fizeau-Interferometer
8 Versuchsdurchführung
8.1 Messungen ebener Flächen
Bei Messungen mit planen Platten wird die planparallele Referenzplatte in die Halterung montiert.
Durch Drücken der Taste „FINDER“ am Handsteuergerät wird eine Konvexlinse in den Strahlengang
eingeschwenkt und es erscheint ein Fadenkreuz.
Justieren Sie zunächst die Referenzplatte durch die beiden „Verkippungs“-Schrauben so, dass der Reflex auf
der Mitte des Fadenkreuzes erscheint. Nun können Sie die zu messende Platte analog justieren, dass beide
Reflexe in der Mitte des Fadenkreuzes interferieren.
Nach Beendigung der Justage drücken Sie nochmals auf die Taste „FINDER“, sodass die
Interferenzmessung beginnen kann. Stellen Sie das Interferenzbild so ein, daß nur noch parallele
Linien angezeigt.werden.
Bevor Sie die automatische Messung starten, überprüfen Sie bitte, ob die Einstellungen in der
Aufnahmedialogbox (Einstellungen>Aufnahme) korrekt sind. Zur Prüfung ebener Flächen sollten nur der
Konstante- und Tilt-Term der Seidel-Koeffizienten abgezogen werden.
8.2 Messungen sphärischer Flächen
Bei Messungen mit sphärischen Flächen z.B. Linsen wird das Referenzobjektiv in die Halterung montiert.
Um eine Interferenzmessung durchführen zu können, muß sich die zu messende Fläche im Fokus des
Messobjektivs befinden, oder den Abstand r (r - Radius des Prüflings) zum Fokuspunkt haben.
Zur Prüfung sphärischer Flächen sollten der Konstante-, Tilt- und Fokus-Term der Seidel-Koeffizienten
abgezogen werden.
8.3 Sondermessungen
Stellen Sie je nach Aufgabenstellung die entsprechende Sondermessung ein und folgen Sie den Anweisungen
im Dialogfenster
8.4 Besonderheiten
Wenn Sie kleinere oder komplexe Objekte vermessen wollen, wird empfohlen, mit einer geeigneten Maske
zu arbeiten. Aktivieren Sie dazu den Menuepunkt “Maske“ z.B. Kreis und drücken Sie die linke Maustaste
etwa in der Mitte des Interferogramms und halten Sie diese gedrückt. Bewegen Sie nun den Mauszeiger an
den Rand des Prüfbereiches und lösen die Taste wieder. Den äußeren, nicht zumessenden Bereich muß noch
geschwärzt werden. Dazu drücken Sie das Icon „Ausmarkierte Bereiche aus den Darstellungen entfernen“
(Quadrat mit schwarzer Kreisfläche). Der geschwärzte Teil lässt sich, falls erforderlich, noch konvertieren.
Seite 48 von 49
Versuch 2: Fizeau-Interferometer
9 Arbeitsprogramm
9.1 Aufgaben
Bevor Sie messen, überprüfen Sie bitte , ob die grüne Lampe am Steuergerät brennt und somit der Laser sich
stabilisiert hat.
1) Montieren Sie den Spiegel1 an den verschiebbaren Halter und messen Sie interferometrisch
die Oberfläche mit der planparallelen Referenzplatte (Automatische Messung mit Fokus).
Drücken Sie am Handsteuergerät die Taste „FINDER“, danach erscheint ein Fadenkreuz. Justieren Sie
zunächst die Referenzplatte durch die beiden „Verkippungs“-Schrauben so, dass der Reflex auf der Mitte
des Fadenkreuzes erscheint. Nun können Sie die zu messende Platte analog justieren, dass beide Reflexe
in der Mitte des Fadenkreuzes interferieren.
Nach Beendigung der Justage drücken Sie nochmals auf die Taste „FINDER“, sodass die Interferenzmessung beginnen kann. Stellen Sie das Interferenzbild so ein, daß es nur noch parallele Linien anzeigt.
2)
Führen Sie mit dem Rohling R1 eine Homogenitätsmessung (Sondermessungen) durch?
3)
Montieren sie das Referenzobjektiv und bestimmen Sie die Oberfläche der Linse 1 (Automatische
Messung ohne Fokus).
4) Bestimmen Sie mit der Würfeleckenmessung (Sondermessungen) die Winkelfehler des Tripelprismas
mit der
a) Single Pass Messung
b) Double Pass Messung
5.) Justieren Sie die Dachwinkelprismen D1 und D2 auf dem Prismentisch und bestimmen Sie die
Winkelfehler (Sondermessungen) mit der
a) Single Pass Messung
b) Double Pass Messung
6.) Führen Sie mit der LINSE3 eine Absolutmessung (Sondermessungen) durch.
7.) Montieren Sie die Keilplatte KEIL1 und bestimmen Sie den Keilwinkelfehler (Sondermessungen).
9.2 Fragen
(Bitte schriftlich beantworten !)
1) Skizzieren Sie den schematischen Aufbau eines Fizeau-Interferometers
2) Erklären Sie den Begriff „Interferenz“.
3) Was bedeutet „Unwrapping“?
4) Erläutern Sie die Bedeutung der Zernike-Koeffizienten
Seite 49 von 49
Herunterladen
Explore flashcards