Die Funktion SVERWEIS Klicken Sie in die Zelle C2 Klicken Sie im

Werbung
-1-
Die Funktion SVERWEIS
Klicken Sie in die Zelle C2
Klicken Sie im Register „Formeln“ – Gruppe „Funktionsbibliothek“ – „Nachschlagen und Verweisen“
Klicken Sie auf SVERWEIS und geben Sie folgende Maske ein
Spaltenindex
aufsteigende Darstellung, es wird immer die
1. Spalte durchsucht
Spalte mit der
Funktion
SVERWEIS
Spalte mit
Suchkriterien
Matrix
$F$3:$G$7
(Suchbereich)
Syntax
=SVERWEIS(Suchkriterium; Matrix; Spaltenindex; Bereich_Verweis)
Beachte: „Matrix“ wird hier mit absolutem Bezug angegeben, um die Formel anschließend kopieren zu können.
Wert ist kleiner als 1. Wert
in der 1. Spalte der Maxtrix,
deshalb besser „0“ eingeben.
-2-
Die Funktion „WVERWEIS“
Umsatz
Provisionssatz
100.000 €
5%
Suchkriterium
Name
Müller
Graf
Reich
Klos
Bieber
Wagner
Erikson
Provisionstabelle
200.000 € 300.000 € 400.000 € 500.000 €
20%
10%
15%
25%
Maxtrix
Zeilenindex
Umsatz
Provisionssatz Provision
300.000 €
15% 45.000 €
157.000 €
5%
7.850 €
515.000 €
25% 128.750 €
262.000 €
10% 26.200 €
473.000 €
20% 94.600 €
98.000 €
#NV
#NV
310.000 €
15% 46.500 €
Die Funktion WVERWEIS arbeitet ähnlich wie die Funktion SVERWEIS. Der einzige Unterschied besteht darin, dass bei der Funktion WVERWEIS die erste Zeile einer Matrix nach einem festgelegten Suchkriterium durchsucht wird.
Syntax
WVERWEIS(Suchkriterium;Matrix;Zeilenindex;Bereich_Verweis)
Beispiellösung
-3Fallbeispiel:
In den Stammdaten soll von jedem Mitglied die Beitragssumme übernommen werden: Die Beitragsdaten stehen auf dem Tabellenblatt "Beiträge"
Jahre
Beitragssatz
Beiträge
10
0,00 €
18
15,00 €
50
25,00 €
65
20,00 €
70
0,00 €
1. Möglichkeit:
Sie verknüpfen das Tabellenblatt "Beiträge" mit dem Tabellenblatt "Stammdaten"






Daten im Tabellenblatt "Beiträge" markieren - strg + c
zum Tabellenblatt "Stammdaten" wechseln
klicken Sie in die Zelle L3 und schreiben Sie "Beiträge"
klicken Sie nun mit der rechten Maustaste auf Einfügen auf das Symbol mit der "liegenden
Schleife" = verknüpfen
Ihr Datenblatt "Beiträge" erscheint auf dem Tabellenblatt "Stammdaten"
Klicken Sie in die Zelle L4 und geben Sie untenstehende Formel ein
K4 = Zelle, auf die sich
die Auswertung bezieht
Erklärung:
$K$12;$L$16 = Matrix
(Bereich, in dem gesucht
werden soll)
=SVERWEIS(K4;$K$12:$L$16;2)
SVERWEIS = Funktion
2 = die Spalte in der Matrix, in der das
auszugebende Kriterium steht. Es sollen hier die €-Beiträge ausgegeben
werden
-42. Möglichkeit
Sie beziehen das Tabellenblatt "Beiträge" automatisch ohne Verknüpfung auf das Tabellenblatt "Stammdaten" ein. Es ändert sich die Formel wie folgt:
=SVERWEIS(K4;Beiträge!$A$9:$B$13;2)
Herunterladen
Explore flashcards