Anwendungsbezogene Funktionen

Werbung
Tabellenkalkulation (Excel) für BWR – Anwendungsbezogene Funktionen
Tabellenkalkulationsprogramme (z.B. Excel) haben eine eigene Syntax
(Rechtschreibregeln)
Abweichende Zeichen:
- für Multiplikation
- für Division
„*“
„/“
statt
statt
„.“
„:“
- für Potenz
„^“
statt
„hochgestellt“
In eine Zelle (Feld) können geschrieben werden:
- Zahlen
(Kennzeichnung nicht notwendig)
- Buchstaben, Wörter
(Kennzeichnung, entweder mit , Leerstelle ,
wird als „Textzelle“ formatiert)
- Formeln, Funktionen
(Kennzeichnung mit „=“ )
„,oder die Zelle
Funktionen sind vorgefertigte, komplexe Formeln
Eine Funktion setzt sich zusammen aus:
1.
2.
3.
„=“ - Zeichen
Funktionsname (z.B. SUMME, ANZAHL, MITTELWERT, WENN)
Zellbezug oder Bereichsbezug
Die einzelnen Funktionen
Die Funktion =SUMME( ) hilft bei der Addition von mehreren bzw. vielen Zellen.
z.B:
=SUMME(A1:A100)
zählt die Inhalte der ersten hundert Zellen der
Spalte A zusammen.
z.B:
=SUMME(A1;A10;B30)
zählt die Inhalte der drei Zellen A1+A10+B30
zusammen.
:
;
Beachte die unterschiedlichen Trennzeichen: „ “ bzw. „ “
Die Funktion =ANZAHL( ) ermittelt die Zahl der Eintragungen innerhalb des
angegebenen Bereiches.
z.B:
=ANZAHL(D10: F12)
zählt, wie viele der Zellen im Bereich
D10,D11,D12,E10,E11, E12,F10,F11,F12 Daten
enthalten.
Die Funktion =MITTELWERT( ) berechnet den Durchschnittswert der Zahlen im
angegebenen Bereich.
z.B:
=MITTELWERT(B2:B4)
Die Funktion =WENN( )
errechnet das arithmetische Mittel aus den drei Zahlen
in den Feldern B2+B3+B4
kann nach Prüfung einer Bedingung zwei verschiedene
„Ergebnisse“ anzeigen.
Zweiseitige Auswahl:
WENN
(Bedingung erfüllt)
DANN
SONST
z.B.: =WENN(D12>0;“Gewinn“;“Verlust“)
schreibt das Wort „Gewinn“, wenn der Wert in Zelle D12 größer ist als 0, bzw. schreibt
„Verlust“, wenn der Wert in D12 kleiner ist als 0.
Achtung: Die Funktion =WENN hat drei Parameter:
=WENN(1;2;3)
;
 das Trennzeichen zwischen den Parametern ist „ “
 Der erste Parameter ist die „Bedingung“
 Der zweite Parameter ist der DANN-Teil
im obigen Beispiel bedeuten die Anführungszeichen, dass das Programm „schreiben“
soll, nämlich das Wort „Gewinn“
 Der dritte Parameter ist der SONST-Teil
(er wird nur ausgeführt, wenn die Bedingung nicht erfüllt ist)
Statt Buchstaben(Wörter) ausdrucken zu lassen, kann man im DANN-Teil und/oder im
SONST-Teil weitere Formeln oder Funktionen, also Berechnungen ausführen lassen.
Die Anführungszeichen bleiben dann weg.
Unterschiedliche Zellformatierung führt zu unterschiedlichen Formeln
Beispiel:
Arbeitsblatt zur Berechnung des Bruttobetrages.
Gegenüberstellung der zwei Versionen
Formatierung Zelle B3: „Zahl“
A
1
2
3
4
B
%
Nettobetrag
+ UST
19
Bruttobetrag
Formatierung Zelle B3: „%“
C
A
1
2
3
4
Nettobetrag
+ UST
Bruttobetrag
B
C
19%
Formel in Zelle C3 lautet:
Formel in Zelle C3 lautet:
= C2*B3/100
= C2*B3
Beide Formeln führen wegen der unterschiedlichen Zellformatierung in den Zellen B3
zu demselben Ergebnis dürfen aber nicht vertauscht werden.
Herunterladen
Explore flashcards